Bug report #6945

SAGA vector produced without .prj if the input layer does not have it

Added by Paolo Cavallini almost 8 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/SAGA
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:16057

Description

This happens e.g. with Contour lines from grid


Related issues

Related to QGIS Application - Bug report #13093: SAGA kernels and other commands are created without a CRS... Closed 2015-07-08

History

#1 Updated by Victor Olaya almost 8 years ago

  • Status changed from Open to Feedback

Does you input file has an assigned CRS?

I am getting a shapefile with a valid prj file, but my input file has a defined CRS. If it doesn't have one, SAGA will not generate a prj, since it cannot know the input CRS.

Do you think that maybe SEXTANTE should warn about this? Or maybe, if the layer used as input for SAGA/GRASS doesn't have a CRS, re-save it with the current project CRS

#2 Updated by Paolo Cavallini almost 8 years ago

You got it, no CRS in input. As this is a general issue, I think the safest option would be to take the CRS used by QGIS project for that layer.

#3 Updated by Filipe Dias about 7 years ago

The title of this ticket should be changed.

#4 Updated by Paolo Cavallini about 7 years ago

  • Subject changed from SAGA vector produced without .prj to SAGA vector produced without .prj if the input layer does not have it

#5 Updated by Giovanni Manghi about 6 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to 2.4.0
  • Category deleted (56)
  • Project changed from 78 to QGIS Application

#6 Updated by Giovanni Manghi about 6 years ago

  • Category set to Processing/SAGA

#7 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Feedback to Open
  • Target version set to Future Release - Lower Priority

#8 Updated by Giovanni Manghi over 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#9 Updated by Paolo Cavallini over 2 years ago

  • Assignee deleted (Victor Olaya)

#10 Updated by Paolo Cavallini over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Fixed in Q3

Also available in: Atom PDF