Bug report #6938

Legend group visibility computation is wrong

Added by Sandro Santilli almost 7 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Legend
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:16051

Description

Adding groups make them marked as "visible" by default, adding layers and setting their visibility to off doesn't change that state.
So you can easily end up with a checked group containing all unchecked layers.

History

#1 Updated by Sandro Santilli almost 7 years ago

Ideally a group should start as not visible and its state should be updated whenever a child layer-or-group visibility gets updated.

#2 Updated by Giovanni Manghi almost 7 years ago

maybe related to #5924 ?

#3 Updated by Sandro Santilli almost 5 years ago

According to Martin this should not be a bug anymore since 2.4: #11382-12

To be checked by dropping workarounds in TopoViewer and check they are not needed anymore:
https://github.com/qgis/QGIS/blob/final-2_4_0/python/plugins/db_manager/db_plugins/postgis/plugins/qgis_topoview/__init__.py#L154-L155

#4 Updated by Sandro Santilli almost 5 years ago

  • Status changed from Open to Closed
  • Target version set to 2.4
  • Affected QGIS version changed from master to 2.2.0
  • Resolution set to fixed/implemented

Confirmed fixed, workaround removed with 93864ce55c9e4ec1a3441f32f73c3166b83ea36c

Also available in: Atom PDF