Bug report #5924

On projects load, groups and subgroups TOC checkboxes are broken

Added by Giovanni Manghi about 7 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Legend
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:15363

Description

I'm recently working with many large projects and I can say that on load the TOC checkboxes are almost always unselected or selected in a wrong way, that is they do not represent correctly if in a group there are for exemple just a few layers active or all or none.

Correcting the status of the checkboxes, saving and reloading is useless.

This happens on both 1.8 and master.

History

#1 Updated by John Tull about 7 years ago

I noticed this, or similar behavior, today. For me, grouped items will turn on when the group tick box is checked. Although the checkboxes for the enclosed item turn off when I "untick" the checkbox, the layers are still rendered. In order to turn off the rendering, they have to be individually unchecked.

Perhaps my issue is separate. I'll file a new bug if that is believed to be warranted.

#2 Updated by John Tull about 7 years ago

This behavior seems to be inconsistent. On my project, the toggles are now working...

#3 Updated by Giovanni Manghi about 7 years ago

to understand what I mean you may want to download this project

http://www.comune.torino.it/geoportale/dati/dati_torino.zip

#4 Updated by Giovanni Manghi almost 7 years ago

  • Subject changed from When loading projects with groups and subgroups TOC checkboxes are often selected in a wrong way to On projects load, groups and subgroups TOC checkboxes are broken

This is till true, I cannot tag this as blocker as it is not a regression, but to me would be not acceptable to release a future version of QGIS without fixing this issue.

#5 Updated by Giovanni Manghi over 6 years ago

  • Priority changed from High to Normal

#6 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Seems fixed in master.

Also available in: Atom PDF