Bug report #6901

Changing symbols to >1 symbology classes leads QGIS to crash

Added by Giovanni Manghi almost 7 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Arunmozhi P
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed
Crashes QGIS or corrupts data:Yes Copied to github as #:16026

Description

This tickets is a follow up of #3275 and affects QGIS master (tested on Windows for now, will do also on Linux).

add a vector layer (tested polygon for now)

do a categorized symbology

select all classes or part of them (anyway > 1)

hit the "change" button to change the symbol of selected classes

change the symbol to something different

when you will click "ok" qgis will crash

It is certainly a regression because in QGIS 1.8 selecting >1 class and trying change the symbols is not working but it is not crashing either.

category-fix.diff Magnifier (1.67 KB) Arunmozhi P, 2012-12-20 12:46 PM

History

#1 Updated by Giovanni Manghi almost 7 years ago

  • Crashes QGIS or corrupts data changed from No to Yes

#2 Updated by Arunmozhi P almost 7 years ago

  • Pull Request or Patch supplied changed from No to Yes
  • File category-fix.diffMagnifier added
  • Resolution set to fixed

Here is the fix.

#3 Updated by Giovanni Manghi almost 7 years ago

  • Status changed from Open to Feedback

Arunmozhi P wrote:

Here is the fix.

thanks!

better doing a pull request on github.

#4 Updated by Arunmozhi P almost 7 years ago

Giovanni Manghi wrote:

better doing a pull request on github.

Done. Here-> https://github.com/qgis/Quantum-GIS/pull/365

#5 Updated by Nathan Woodrow over 6 years ago

  • Status changed from Feedback to Resolved

Fixed in c41988824

#6 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Resolved to Feedback

I'll test it asap.

#7 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF