Bug report #6898

QGIS mapserver forces http when requesting SLD=https

Added by Marco Lechner over 7 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:René-Luc ReLuc
Category:QGIS Server
Affected QGIS version:2.18.22 Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:16023

Description

When trying to use SLD with QGIS mapserver including SLD in GetMap requests qgis-mapserver tries to fetch the SLD-file using only http. Having SLD=https:///www.foo.de/mysld.xml is taken as http:///www.foo.de/mysld.xml - if sld-files are only available via https qgis mapserver can not fetch them. A "premature end of script" error is thrown.

As another side-effect using SLD=https:///www.foo.de:443/mysld.xml with results in a 400 bad request error, because qgis mapserver tries to ftech http:///www.foo.de:443/...

Solution: qgis mapserver should respect https (well, how to handle self-signed certificates then?)

Associated revisions

Revision a5dd6eb8
Added by René-Luc ReLuc almost 2 years ago

[BUGFIX][Server] Quickfix in QgsHttpTransaction to support HTTPS scheme

The class QgsHttpTransaction is only used in server for getting files provided by URL. This class does not support HTTPS.

This is a quickfix to enable requesting SLD files provided through HTTPS scheme.

Fixes #6898 QGIS mapserver forces http when requesting SLD=https https://issues.qgis.org/issues/6898 a five year old issue.

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#2 Updated by René-Luc ReLuc almost 2 years ago

  • Affected QGIS version changed from master to 2.18.22
  • Pull Request or Patch supplied changed from No to Yes
  • Assignee set to René-Luc ReLuc
  • Description updated (diff)

#3 Updated by René-Luc ReLuc almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#4 Updated by Giovanni Manghi almost 2 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF