Bug report #6891

Connection to non-spatial PostgreSQL

Added by Paolo Cavallini over 7 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/PostGIS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16016

Description

QGIS throws an error when trying to connect to a plain (non PostGIS) db. I think this limitation should be removed, because:

- QGIS can load non spatial tables, so also a non spatial db is somehow usable
- EXTENSION postgis can be created from within QGIS (e.g. through DB Manager), so an
user could connect to a non spatial PostgreSQL and make it spatial.


Related issues

Duplicated by QGIS Application - Bug report #14211: Cannot add Postgres geometryless layers if postgis extens... Closed 2016-02-01

Associated revisions

Revision 94413b35
Added by Jürgen Fischer almost 4 years ago

postgres provider: allow database without postgis (fixes #6891)

Revision 57c199f3
Added by Jürgen Fischer almost 4 years ago

postgres provider: allow database without postgis (fixes #6891)

(cherry picked from commit 94413b35a08a154e5b40c2a9cab13fcb0d0ee4a4)

History

#1 Updated by Giovanni Manghi about 4 years ago

see also #14211

#2 Updated by Jürgen Fischer almost 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF