Bug report #6836

Label with "using perimeter" option looses label and do not work as expected

Added by Regis Haubourg almost 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Normal
Assignee:Larry Shaffer
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15974

Description

Hi,
Using perimeter labeling option is not working well when labeling a polygon not entirely contained in mapCanvas extent. Polygon is clipped with extent and label is applied to that part.
Two major drawbacks:
- when using options above-on-below line, some labels are drawn outside screen extent. See joined screen capture. when using below line option, label disappear at the bottom and right side of the canvas. Reversed behaviour for "above" option. Half cut label for "On" OPtion
- Apart from drawing labels outside the screen, thhos labels shouldn't be drawn on Side of mapCanvas, but following the uncropped lines inside mapCanvas? See third image that simulate the theorical behaviour expected.

As a solution, I suggest that polygons intersecting current extent be converted to lines and clipped with extent, and labeled with same algorithm as "Line" uses. That way, only real boundary can be used to label polygon. That would solve both issues.
regards.
I'm affecting it to Larry because I know he has a good global vision of labeling tools. Feel free to reaffect
Régis

History

#1 Updated by Regis Haubourg almost 7 years ago

  • Status changed from Open to Closed

duplicate of #6835

Also available in: Atom PDF