Bug report #6697

Missing "not" operator

Added by Jonathan Moules over 7 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:1.8.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:15862

Description

In the raster calculator, there is no "Not" operator to click on. This is a problem because its not clear which of the many "not" operators the calculator uses (https://en.wikipedia.org/wiki/!=#Standard_relational_operators)

After some testing, it appears to be: !=

History

#1 Updated by Médéric RIBREUX over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Hello, bug triage...

as you said, "NOT" operator is "!=". It seems to be coherent with other operators naming on the raster calculator: there is no "IS" operator for equality test, just "=" sign instead.

I think we can close this bug...

Also available in: Atom PDF