Bug report #6504

Segfault on Mac OS X with new QgsRasterBlock class

Added by Larry Shaffer almost 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Radim Blazek
Category:Rasters
Affected QGIS version:master Regression?:No
Operating System:Mac OS X Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:Yes Copied to github as #:15723

Description

The segfault occurs when loading some projects with raster layers and when running raster unit tests.

The unittests are:

qgis_composerscalebartest - http://dash.orfeo-toolbox.org/testDetails.php?test=12507593&build=98288

qgis_projectionissues - http://dash.orfeo-toolbox.org/testDetails.php?test=12507595&build=98288

Attached are the Mac OS X crash reports for each. (there is a <-!!! at the end of the line where QgsRasterBlock might be causing the issue )

qgis_composerscalebartest_2012-10-12-083430_larrys-imac-crash.txt Magnifier (53.5 KB) Larry Shaffer, 2012-10-12 01:22 PM

qgis_projectionissues_2012-10-12-083437_larrys-imac-crash.txt Magnifier (52.2 KB) Larry Shaffer, 2012-10-12 01:22 PM

History

#1 Updated by Radim Blazek almost 7 years ago

Fixed in 000f689.

The problem was in QgsRasterProjector::block() using wrong indexes to in/out blocks.

#2 Updated by Radim Blazek almost 7 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Also available in: Atom PDF