Bug report #6405

Show feature count not working with rule-based label definitions

Added by Mathieu Pellerin - nIRV about 8 years ago. Updated about 8 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:15658

Description

Not sure when this regressed. With latest nightly build, QGIS fails to provide count numbers to layer's labels defined with rule-based definitions. See attached screenshot.

I've also included in this issue the tiny project + shapefile as test case.

qgis-count-broken.jpg (161 KB) Mathieu Pellerin - nIRV, 2012-09-24 07:11 PM

count-broken-project.zip (400 KB) Mathieu Pellerin - nIRV, 2012-09-24 07:11 PM

History

#1 Updated by Giovanni Manghi about 8 years ago

  • Status changed from Open to Feedback

is this a regression from 1.8? or it used to work in master and then stopped?

#2 Updated by Regis Haubourg about 8 years ago

Hi all,
I've never seen this working. see: #5768, #5960, #3402 , #6237..
Theses features are currently being sponsored, you should here news of it very soon here.
régis

#3 Updated by Mathieu Pellerin - nIRV about 8 years ago

Ah, so I couldn't remember when it regressed because it never did regress :o)

Regis, glad to hear this feature is being worked on. What do you want me to do with this bug? Close it as duplicate of another issue (if so, which one), or leave it open as requested feature?

M

#4 Updated by Regis Haubourg about 8 years ago

It's a duplicate .. maybe better to close it to help dev's reduce noise in this bugtracker. Giovanni, opinion?

#5 Updated by Mathieu Pellerin - nIRV about 8 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

(Closed as duplicate of issue #5768)

Also available in: Atom PDF