Bug report #6351

field calculator: correct calculation, but nulls written to table

Added by Alister Hood almost 8 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:1.8.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:15623

Description

- Load a shapefile, open the attribute table and enable editing.
- Add a column, fill in values manually, click the save button.
- Close the attribute table and reopen it.
Usually the values are saved successfully, occasionally the values are all NULL.
The same problem can also occur when using the field calculator to fill in the values.

I have heard a report that this problem still occurs in QGIS 1.8, but I don't know about current master.

History

#1 Updated by Christian Urich almost 8 years ago

Same here on Ubuntu 12.04 QGIS 1.8. The problem is when I use a shapefile and choose a field name with more than 10 characters the result is NULL. If I work on PostGIS everything is fine (can handle longer field names)

#2 Updated by Médéric RIBREUX almost 5 years ago

  • Resolution set to not reproducable
  • Status changed from Open to Closed

Hello, bug triage...

On QGIS master (2.13), I am not able to reproduce the bug on shapefiles, using text/integer/decimal new fields on more than 5 different sessions with one different Shp file (with specific attributes).

Feel free to reopen it if you still encounter it !

Also available in: Atom PDF