Bug report #6312

New diagrams: zooming out creates large, out of context pies

Added by Paolo Cavallini about 8 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:C++ Plugins
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15604

Description

See attached

12.png (149 KB) Paolo Cavallini, 2012-09-06 12:36 AM

History

#1 Updated by Matthias Kuhn about 8 years ago

As far as I can see, these pies are placed by the PAL engine. The
easiest solution would be to check if one of the following works for you:

- Enabling scale dependent visibility and hide the small diagrams
- choose another placement method (over point / free)

#2 Updated by Paolo Cavallini about 8 years ago

The problem I see is that when zooming out, pies become larger. I admit this is a corner case, possibly meaningless in most situations.

#3 Updated by Paolo Cavallini about 8 years ago

  • Subject changed from New diagrams: zooimg out creates large, out of context pies to New diagrams: zooming out creates large, out of context pies

#4 Updated by Matthias Kuhn over 7 years ago

  • Status changed from Open to Closed

Closing as this is not a bug.

If necessary, reopen and provide information about expected behavior.

Also available in: Atom PDF