Bug report #6254

Distance Matrix doesn't work with postgis vector

Added by Sergio Vignali about 7 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/QGIS
Affected QGIS version:master Regression?:
Operating System: Easy fix?:
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:15560

Description

I tried to use a Distance Matrix with a postgis vector and I obtained a illeggible csv file. If I save the postgis vector as a shp file the Distance Matrix works well.

History

#1 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#2 Updated by Giovanni Manghi over 6 years ago

  • Affected QGIS version changed from 1.8.0 to master
  • OS version deleted (UBUNTU 12.04)
  • Operating System deleted (Linux)
  • Priority changed from Normal to High

It still doesn't work for PostGIS layers, as the matrix is full of zeroes. Curios enough, re-saving the vector as shape does not seems to solve the issue, as the resulting matrix is still wrong.

#3 Updated by Paolo Cavallini almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority

#4 Updated by Giovanni Manghi almost 6 years ago

  • Priority changed from High to Normal

There is no crash or data corruption, so I'm lowering the priority.

#5 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

#6 Updated by Giovanni Manghi over 2 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF