Bug report #6206

Categorized Style Delete button doesn't delete selected classes

Added by Médéric RIBREUX about 7 years ago. Updated about 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:1.8.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:15519

Description

Hello,

The behavior of the Delete button on the Categorized Style dialog is not complete. It doesn't delete the selection but only the last selected class. As a consequence, it is particulary boring to delete lots of classes, one by one and this behavior is far from natural.

You can see an example with the added png files: only the last selected class (PHAE.NOR) is deleted when you clic on the delete button.

qgis_categorized_style_before_delete.png - The class selection to delete (35 KB) Médéric RIBREUX, 2012-08-16 03:14 AM

qgis_categorized_style_before_after.png - Only the last class is really deleted (33.9 KB) Médéric RIBREUX, 2012-08-16 03:14 AM

History

#1 Updated by Giovanni Manghi about 7 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #5611

Also available in: Atom PDF