Bug report #6146

Offline editing tool broken

Added by Giovanni Manghi over 7 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:vinayan Parameswaran
Category:C++ Plugins
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15473

Description

  • pick a postgis layer
  • put it in off-line mode
  • start editing
  • QGIS won't auto-increment the primary key
  • if no primary key is entered, when synchronizing PostGIS will throw an error saying that gid canoot be NULL
  • the user can manually enter the values for primary keys and synchronizing will work, but then when adding new features PostGIS will throw an error like "_Provider errors: PostGIS error while adding features: ERROR: duplicate key value violates unique constraint "teste_pkey"_"

A regression since 1.7.4? if someone can confirm please tag this as blocker.

Associated revisions

Revision 8b8eb562
Added by Martin Dobias almost 6 years ago

Fix #6146 (Offline editing tool broken)

Adding of features back to remote database didn't work in case of primary keys
being auto-generated. With the fix, if the user did not set any value (i.e. it is NULL),
the value will be set to provider's default (and thus use the sequence generator)

History

#1 Updated by Giovanni Manghi about 7 years ago

  • Priority changed from High to Severe/Regression

regression confirmed. who is the maintainer?

#2 Updated by Giovanni Manghi about 7 years ago

  • Subject changed from Offline editing tool broken(?) to Offline editing tool broken

#3 Updated by Giovanni Manghi over 6 years ago

  • Crashes QGIS or corrupts data changed from No to Yes

tested again on qgis master on Ubuntu, it seg faults the program now when starts creating the SL file.

#4 Updated by Giovanni Manghi over 6 years ago

  • Crashes QGIS or corrupts data changed from Yes to No

Giovanni Manghi wrote:

tested again on qgis master on Ubuntu, it seg faults the program now when starts creating the SL file.

it crashes qgis master also under Windows.

#5 Updated by Giovanni Manghi over 6 years ago

On qgis 1.8 on Windows it now returns a

"Could not open the spatialite database"

when trying to put off line some vector.

#6 Updated by vinayan Parameswaran over 6 years ago

  • Assignee set to vinayan Parameswaran

#7 Updated by vinayan Parameswaran over 6 years ago

  • Pull Request or Patch supplied changed from No to Yes
  • % Done changed from 0 to 100

#8 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Open to Feedback

https://github.com/qgis/Quantum-GIS/pull/586

fixes it (Thanks Vinayan!)

but right now I can't compile the latest code as it gives an error, so closing this is pending later tests.

cheers!

#9 Updated by vinayan Parameswaran over 6 years ago

Giovanni,
Pull request was merged today..so you should be able to test master
cheers!

#10 Updated by Giovanni Manghi over 6 years ago

vinayan Parameswaran wrote:

Giovanni,
Pull request was merged today..so you should be able to test master
cheers!

yes, problem is that the latest code revision is not compiling for me right now, so I must wait for a new build for Ubuntu and/or Windows.

cheers!

#11 Updated by Giovanni Manghi over 6 years ago

Hi, I just tested https://github.com/qgis/Quantum-GIS/pull/586 on Windows/osgeo4w (will do also on Linux) and does not work.

What I see:

I add a PostGIS layer

click on "convert to offline project"

it is asked to save a SL DB and choose the postgis layer to put offline

when clicking "ok" the SL is created but...

the layer in the TOC remain the PostGIS one (it shold show also a "offline" in layer name, as it did in 1.7.4)

the SL DB is empty

the synchronize button is active, when clicked causes qgis to crash

#12 Updated by Giovanni Manghi over 6 years ago

Giovanni Manghi wrote:

Hi, I just tested https://github.com/qgis/Quantum-GIS/pull/586 on Windows/osgeo4w (will do also on Linux) and does not work.

What I see:

I add a PostGIS layer

click on "convert to offline project"

it is asked to save a SL DB and choose the postgis layer to put offline

when clicking "ok" the SL is created but...

the layer in the TOC remain the PostGIS one (it shold show also a "offline" in layer name, as it did in 1.7.4)

the SL DB is empty

the synchronize button is active, when clicked causes qgis to crash

on Linux it seems to work. There is always the (huge) issue (#7550) when splitting geometries, that is broken with SL and PostGIS and affects obviously also the off-line tool.

#13 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Feedback to Open

#14 Updated by vinayan Parameswaran over 6 years ago

Hi Giovanni,
I have submitted a pull that addresses the issue in windows..
https://github.com/qgis/Quantum-GIS/pull/634

#15 Updated by vinayan Parameswaran over 6 years ago

Hi Giovanni,

got time to test this?

#16 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

vinayan Parameswaran wrote:

Hi Giovanni,

got time to test this?

Hi!

yes it is fixed!

there is till this issue #7550 that limits the editing operations when off-line, but that is a completely different problem.

Thanks!

#17 Updated by Giedrius Vaivilavičius almost 6 years ago

On QGIS 2.0.1 synchronization problem remains (OS Ubuntu 12.04, Debian Wheezy).

Using qgiscloud plugin uploads a postgis layer. Before editing offline:

After editing offilene:

When I click on sync:

As a result, I have to manually enter the ID numbers because it does not save data:

How to solve this?

#18 Updated by Giovanni Manghi almost 6 years ago

  • Resolution deleted (fixed)

How to solve this?

the tool is broke, so you may want to a) wait for the fix or b) support its fix

#19 Updated by Giedrius Vaivilavičius almost 6 years ago

  • Status changed from Closed to Reopened

#20 Updated by Paolo Corti almost 6 years ago

Confirmed. I am experiencing the same.

#21 Updated by Paolo Cavallini almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority

#22 Updated by Martin Dobias almost 6 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF