Bug report #6099

Save as... for raster: missing extension on Gnome3

Added by Paolo Cavallini almost 8 years ago. Updated about 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15444

Description

The file saved misses the file extension (e.g. .tif); it has to be entered by hand

saveasraster.mp4 (1.65 MB) Giovanni Manghi, 2015-05-30 12:08 AM

Associated revisions

Revision 2125f6ac
Added by Salvatore Larosa about 5 years ago

Fix #6099 - Save as... for raster: missing extension on Gnome3

Revision 1edcf3c4
Added by Salvatore Larosa about 5 years ago

Fix #6099 - Save as... for raster: missing extension on Gnome3

(cherry-picked from 2125f6a)

History

#1 Updated by Paolo Cavallini almost 8 years ago

  • Target version set to Version 2.0.0

#2 Updated by Radim Blazek almost 8 years ago

There is one problem. The format may be changed after the file was selected. What should then happen? The vector save as dialog suffers of the same problem.

One solution would be to ask for file after the dialog is accepted.

#3 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#4 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

#5 Updated by Paolo Cavallini about 5 years ago

  • Resolution deleted (fixed/implemented)
  • Status changed from Closed to Reopened

Still true here, just tested on master/deb.

#6 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Reopened to Feedback

Paolo Cavallini wrote:

Still true here, just tested on master/deb.

also tested on master both Linux and Windows, and works as expected.

#7 Updated by Paolo Cavallini about 5 years ago

Steps to reproduce:
  • open a raster
  • legend>right click>Save as
  • leave as default
  • Browse>add output nname as `test` (without extension)
  • the file is saved as `test` (without extension)

#8 Updated by Giovanni Manghi about 5 years ago

Paolo Cavallini wrote:

Steps to reproduce:
  • open a raster
  • legend>right click>Save as
  • leave as default
  • Browse>add output nname as `test` (without extension)
  • the file is saved as `test` (without extension)

see attached screencast

#9 Updated by Paolo Cavallini about 5 years ago

Possibly due to file selector, different here (Gnome3).

#10 Updated by Giovanni Manghi about 5 years ago

  • Subject changed from Save as... for raster: missing extension to Save as... for raster: missing extension on Gnome3
  • Category changed from Rasters to GUI
  • Status changed from Feedback to Open

#11 Updated by Salvatore Larosa about 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF