Bug report #6056

Cannot load WCS layers

Added by Rui Pedro Henriques about 7 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:Radim Blazek
Category:Web Services clients/WCS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15418

Description

When trying to load WCS layers from the server, I always get the "The layer is not a valid layer and can not be added to the map" message. Also, when selecting the layer from the list, the information is that there are 0 CRS available.

The authentication seems to work and the layer list is shown accordingly.

The server I'm using is Geoserver 2.1.3 and can be accessed here: http://geoserver-dev-1.irradiare.com:8080/geoserver/

Apparently it works with gvsig.

History

#1 Updated by Giovanni Manghi about 7 years ago

  • Category set to Web Services clients/WCS
  • Operating System deleted (Ubuntu Linux)
  • OS version deleted (12.04 64 bit)

I have also seen this issue using Mapserver. If I remove authentication (basic http auth) it works as expected.

#2 Updated by Rui Pedro Henriques about 7 years ago

To clarify: the gvSIG test was without authentication. As far as I know gvSIG does not support authentication.

#3 Updated by Paolo Cavallini about 7 years ago

  • Target version set to Version 2.0.0

#4 Updated by Radim Blazek almost 7 years ago

I am not able to get it working with gvSIG-1_11-1305-final, which version of gvSIG are you using?

WCS 1.0.0 (http://geoserver-dev-1.irradiare.com:8080/geoserver/ows?service=wcs&version=1.0.0&request=GetCapabilities) gives error:

java.io.IOException 
null Translator error No input stream for the provided source Details:
org.geoserver.platform.ServiceException: java.io.IOException at
org.geoserver.ows.Dispatcher.exception(Dispatcher.java:1397) at 
...

I'll look also at WCS 1.1.1 but the server is currently down.

#5 Updated by Giovanni Manghi almost 7 years ago

Radim Blazek wrote:

I am not able to get it working with gvSIG-1_11-1305-final, which version of gvSIG are you using?

WCS 1.0.0 (http://geoserver-dev-1.irradiare.com:8080/geoserver/ows?service=wcs&version=1.0.0&request=GetCapabilities) gives error:
[...]

I'll look also at WCS 1.1.1 but the server is currently down.

Radim, in Essen I can give and hand to help debug WCS problems with QGIS or other clients.

#6 Updated by Rui Pedro Henriques almost 7 years ago

Sorry, I've setup that server only for your tests and was not monitoring it, so it went down without me noticing it. I've rebooted the machine and it's online again.

Strangely, now I get an error requesting WCS 1.0.0 but WCS 1.1.1 response looks OK.

Unfortunately, I no longer have gvSIG installed so I don't know which version I was using. I'll try testing this again and report the version.

Meanwhile I'll try to figure out what's going on with the server.

#7 Updated by Rui Pedro Henriques almost 7 years ago

just to inform that I had to take the server offline and for now I don't have the possibility to provide a new one. If I manage to get a new one, I'll keep you informed. Sorry.

#8 Updated by Radim Blazek about 6 years ago

  • Status changed from Open to Feedback

#9 Updated by Radim Blazek over 5 years ago

Closing because of no feedback over 1 year. Please reopen if necessary.

#10 Updated by Radim Blazek over 5 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF