Bug report #6045

postgis: duplicate key when merging polygons

Added by William Kyngesburye about 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/PostGIS
Affected QGIS version:1.8.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15414

Description

When merging features (polygons) in a PostGIS database, when I save changes I get a duplicate key error. I'm copying attributes from one of the merged polygons, including the primary key. It looks like what is happening in the save is that QGIS first adds new features (the merged polygon is counted as new), then deletes old features (the pre-merged pieces). If I save a second time, there is no error because the old pieces have now been deleted.


Related issues

Duplicates QGIS Application - Bug report #5758: Primary key issue when using merge attributes of selected... Closed 2012-06-07

History

#1 Updated by Paolo Cavallini about 7 years ago

  • Target version set to Version 2.0.0

#2 Updated by Julien Lamarche almost 7 years ago

  • Status changed from Open to Closed

The duplicate #5758 has been resolved.

Also available in: Atom PDF