Bug report #5962

"Merge Shapefile to one" crashes QGIS if .prj files are missing

Added by Gerhard Spieles over 7 years ago. Updated over 2 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Processing/QGIS
Affected QGIS version:1.8.0 Regression?:
Operating System: Easy fix?:
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:Yes Copied to github as #:15382

Description

Running the merge shapefile to one process, qgis 1.8.0.1 crash on windows

vektor_merge_to_one_crash_qgis.jpg (289 KB) Gerhard Spieles, 2012-07-06 05:54 AM

vektor_merge_to_one_crash_qgis_settings.jpg (307 KB) Gerhard Spieles, 2012-07-06 03:46 PM

qgiscrashmerge.zip (428 KB) Gerhard Spieles, 2012-07-06 03:46 PM


Related issues

Related to QGIS Application - Bug report #5251: if "Options -> CRS -> coordinate reference system for new... Closed 2012-03-28

History

#1 Updated by Alexander Bruy over 7 years ago

  • Priority changed from High to Normal

Please provide more info about issue(which options are used) and attach sample dataset to reproduce bug

#2 Updated by Gerhard Spieles over 7 years ago

jpg with settings and a sample dataset are attached

#3 Updated by Giovanni Manghi over 7 years ago

This seems a duplicate of #3077 that was already tagged as fixed.

#4 Updated by Giovanni Manghi over 7 years ago

  • OS version deleted (XP 32, SP3)
  • Operating System deleted (win)
  • Target version set to Version 2.0.0
  • Priority changed from Normal to High
  • Subject changed from Vector, Datamanagment, Merge Shapefile to one crash qgis 1.8.0 to "Merge Shapefile to one" crashes QGIS if .prj files are missing

So it is not solved... it seg fault on my Linux box. Adding the prj files and it works fine.

#5 Updated by Gerhard Spieles over 7 years ago

In QGis ver. 1.7.1, gdal 1,8, it works fine without prj file.
versions 1.7.4, 1,8.0 and master, all gdal 1.9, are infected with the crash, missing the prj file.

#6 Updated by Alexander Bruy over 7 years ago

Related to #5251 (or even duplicate)

This is because now QGIS asks for CRS when opened layer without projection information. Seems calling this dialog from thread causes crash.

#7 Updated by Giovanni Manghi about 7 years ago

Alexander Bruy wrote:

Related to #5251 (or even duplicate)

strange, this still causes crash while #5251 does not.

#8 Updated by Giovanni Manghi almost 7 years ago

  • Priority changed from High to Severe/Regression

gespiel - wrote:

In QGis ver. 1.7.1, gdal 1,8, it works fine without prj file.
versions 1.7.4, 1,8.0 and master, all gdal 1.9, are infected with the crash, missing the prj file.

if it worked fine in a previous qgis version then this is regression.

#9 Updated by Giovanni Manghi almost 7 years ago

probable duplicate of #5251

#10 Updated by Giovanni Manghi almost 7 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

#11 Updated by Giovanni Manghi over 2 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF