Bug report #595

SnapDistance:

Added by stephan-holl-intevation-de - over 13 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10654

Description

The snapdistance does not work as expected when moving vertices on postgis-layers.
Furthermore the window with the hint how to solve this pops up twice which is not nice.

Anyway, changing the suggested value does not solve the issue.

Thanks for looking into this.

History

#1 Updated by Marco Hugentobler over 13 years ago

The double pop-up is removed now.
Could you give a more detailed description of when and how the snapping does not work (e.g. use of reprojection)? Where you not able to snap at all or is it the snap behaviour which is not as expected (e.g. snap to vertices of the same feature)?

cheers,
Marco

#2 Updated by stephan-holl-intevation-de - over 13 years ago

HI Marco, sorry for beeing unprecise. I had problems to add new vertices on my postgis-layer which was not reprojected. I used the normal SRID provided by postgis.

Main task was to add a new vertex on a polygon border. I had to directly click to the line in order to add the vertex.
This behaviour was identical on windows and linux version 0.8.0.

#3 Updated by Marco Hugentobler over 13 years ago

Hi Stephan,

Snapping for adding vertices works for me in 0.8. Are you sure you set the snapping tolerance in map units (not in pixels like in GRASS digitizing)?
One problem may be that the snapping is also done to vertices of the same feature. So if the tolerance is high, the new vertex is directly snapped onto another one. Maybe we should snap only to vertices of other features.

If you have the data as shape it will be good for me to reproduce.

Marco

#4 Updated by stephan-holl-intevation-de - over 13 years ago

Marco, you got me!

I thought the distance were pixels (as in GRASS)... Setting a larger snapdistance the snapping to my polygon-borders now works like a charm!
Adding a hint on a prominent place that snapdistance is in map-units would be good thought!

We should change the type of this "bug" to "enhancement" though. Thank you for your help.

Stephan

#5 Updated by Tim Sutton over 13 years ago

Moved to milestone 0.8.2 since we wont be fixing any further issues before the 0.8.1 release

#6 Updated by Marco Hugentobler over 13 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Ok, I changed the string in the project properties to 'snapping distance (in map units)'

Marco

#7 Updated by Anonymous about 11 years ago

Milestone Version 0.8.2 deleted

Also available in: Atom PDF