Bug report #5851

WMS projection from EPSG:4326 to EPSG:900913 cut part of the layer

Added by Paolo Corti over 7 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:15320

Description

I am using the following WMS layer without problems in OpenLayers and other desktop clients
using EPSG:900913 (original dataset is EPSG:4326)

url: http://geohub.jrc.ec.europa.eu/forest/effis/effis_core?
layer: layer:effis:stats_temp

With QGIS, adding it as a WMS, it seems that for some reasons there is a malfunction: the dataset is cut in corrispondence of the Scandinavian penisula, like you can see in the attached images.

wmst-openlayers.png - wms layer as it should be correctly projected (from OpenLayers) (456 KB) Paolo Corti, 2012-06-22 09:14 AM

wmst-qgis.jpg - wms layer uncorrectly projected (in QGIS) (274 KB) Paolo Corti, 2012-06-22 09:14 AM

History

#1 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#2 Updated by Giovanni Manghi almost 7 years ago

  • Priority changed from High to Normal

#3 Updated by Jürgen Fischer over 5 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#4 Updated by Médéric RIBREUX almost 4 years ago

  • Status changed from Open to Feedback

Hello, bug triage...

I can't reproduce it on QGIS 2.13 master (it should also work in QGIS 2.12.1). I am using the same layer with EPSG:900913 and my project CRS is EPSG:900913 OTF.

Can you confirm that this bug is fixed ?

#5 Updated by Giovanni Manghi almost 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

yes, seems fixed in master (while is still not ok on 2.8.5).

Also available in: Atom PDF