Bug report #5812

DB manager does not show the "postgis" section if Postgis is 2.0

Added by Giovanni Manghi over 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Low
Assignee:Giuseppe Sucameli
Category:DB Manager
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15295

Description

When clicking on a connection in DB manager it returns a list of useful informations, but if the DB is postgis 2 it seems to miss the "Postgis" section, as it happens when postgis is of a prior verison, like

PostGIS

Library:
1.5.3
Scripts:
1.5 r5976
GEOS:
3.2.2-CAPI-1.6.2
Proj:
Rel. 4.7.1, 23 September 2009
Use stats:
True

Associated revisions

Revision 3542b089
Added by Giuseppe Sucameli almost 7 years ago

dbmanager: fix #5812,
move PG informations to postgis/info_model.py

History

#1 Updated by Salvatore Larosa over 7 years ago

The reason is that postgis_uses_stats()[1] function is deprecated!
DBManager still uses it!

[1] - http://trac.osgeo.org/postgis/ticket/1632

#2 Updated by Paolo Cavallini about 7 years ago

  • Target version set to Version 2.0.0

#3 Updated by Giuseppe Sucameli almost 7 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF