Bug report #5750

QGIS GUI suddenly stopped working, even after reinstall

Added by gertjan Idema over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:1.7.4 Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:15256

Description

All of a sudden, my QGIS stopped working.
Everything was fine on Sunday, but on Monday the GUI didn't start.
When I try to start QGIS now, the start-up screen appears, up to the "QGIS Ready!" message.
After that, the qgis process is sleeping in the background, I don't get a user interface.

I completely removed QGIS and reinstalled it, but to avail.
I tried two versions: http://qgis.org/debian natty and ubuntugis-unstable-natty, but found no difference.
As far as I can remember and verify in the update log I didn't update any software on my machine
between the last time QGIS was working fine and the moment it stopped working.

Any suggestions?

History

#1 Updated by Paolo Cavallini over 7 years ago

Please start it from a terminal and report back

#2 Updated by Jürgen Fischer over 7 years ago

try renaming ~/.config/QuantumGIS and/or ~/.qgis

#3 Updated by gertjan Idema over 7 years ago

Thanks, I forgot to mention I already tried this. Here's the result:

Warning: loading of qgis translation failed [/usr/share/qgis/i18n//qgis_en_US]
Warning: loading of qt translation failed [/usr/share/qt4/translations/qt_en_US]
Python support ENABLED :-)
Loaded : OpenStreetMap plugin (package: osm)
Loaded : Plugin Installer (package: plugin_installer)
Loaded : fTools (package: fTools)

Because of the translation warnings, I also tried with --lang de :

Python support ENABLED :-)
Loaded : OpenStreetMap plugin (package: osm)
Loaded : Plugin Installer (package: plugin_installer)
Loaded : fTools (package: fTools)

In both cases no GUI appears, but the qgis process is running in the background.
It quits after closing the terminal.

#4 Updated by gertjan Idema over 7 years ago

@Jurgen: Thanks, that did the trick
I tried renaming ~/.qgis already, also before the reinstall but that didn't help.
After renaming ~/.config/QuantumGIS the program starts again.

Now I can start adding the plugins I need to see if the problem reappears.

#5 Updated by Jürgen Fischer over 7 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed
  • Priority changed from Severe/Regression to Normal

Also available in: Atom PDF