Bug report #5688

Presence of an empty shapefile issues a zoom bug

Added by I. Rinn over 7 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:1.7.4 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:15223

Description

If amongst the layers there's a shapefile without features (empty), zooming to all layers leads to an extension of the map with very very small scale (12 digits at denominator!).

The issue is independent by the CRS of layers and the map (tried with several CRS and with or without OTF projection).

History

#1 Updated by Paolo Cavallini about 7 years ago

  • Target version set to Version 2.0.0

#2 Updated by Giovanni Manghi about 6 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

seems fixed, at least in qgis 2.0

Also available in: Atom PDF