Bug report #5576

Paths with accented characters give error when opening files

Added by Pierre-Luc Auclair over 7 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System:WinXP Easy fix?:No
Pull Request or Patch supplied:No Resolution:up-/downstream
Crashes QGIS or corrupts data:No Copied to github as #:15156

Description

If you try to open a file and its path contains accented characters, the file will not load, giving error : ".../is not a valid or recognized data source".

From osgeo4w setup.

History

#1 Updated by Pierre-Luc Auclair over 7 years ago

Note, this doesn't seem to happen on every type of file formats.

.xls files do not work, while .shp do.

#2 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Open to Feedback

It is a blocker only if it is a regression (in qgis-master aka 1.8 aka Lisboa) since 1.7.4, con you confirm is a regression?

#3 Updated by Pierre-Luc Auclair over 7 years ago

I can't confirm it's a regression.

#4 Updated by Giovanni Manghi over 7 years ago

  • Priority changed from Severe/Regression to Normal

Pierre-Luc Auclair wrote:

I can't confirm it's a regression.

ok, I'll change the priority, change it again if you have evidence it is a regression. Cheers!

#5 Updated by Jürgen Fischer over 7 years ago

  • Status changed from Feedback to Open

#6 Updated by Pierre-Luc Auclair about 7 years ago

I just tried with latest builds, it's still broken for .xls files. It seems to be the only problematic filetype. It's not in the supported formats when you import a layer nor does it show up in the browser window, is it possible that QGIS doesn't know how to handle the paths for this new filetype yet ?

#7 Updated by Pierre-Luc Auclair about 7 years ago

Still broken, what's the status on this ?

#8 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#9 Updated by Minoru Akagi about 6 years ago

This issue has already been fixed in GDAL. With GDAL 1.10, we will be able to open xls files that include non-ascii characters in the paths on Windows.

#10 Updated by Giovanni Manghi about 6 years ago

  • Resolution set to up-/downstream
  • Status changed from Open to Closed

Also available in: Atom PDF