Bug report #5525

"Show selected only" in the Attribute table causes QGIS to crash when the number of selected features is high

Added by Filipe Dias over 7 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:15123

Description

"Show selected only" in the Attribute table causes QGIS to crash when the number of selected features is high


Related issues

Related to QGIS Application - Bug report #3838: Selecting features from the table of attributes freezes QGIS Closed

Associated revisions

Revision 47c10db1
Added by Matthias Kuhn over 6 years ago

[FIX #5525] Attribute table performance for large tables
The selection handling performance has been improved a lot
Introduces also more detailed signalling of selection change from QgsVectorLayer

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Crashes QGIS or corrupts data changed from No to Yes

what version of QGIS? There is any difference between 1.7.4 and master? What means "high", 1000? 100000? 1000000?

#2 Updated by Filipe Dias over 7 years ago

It affect both Master and 1.7.4 and the exact number of features is 11438.

#3 Updated by Giovanni Manghi over 7 years ago

  • Priority changed from Normal to High

#4 Updated by Salvatore Larosa over 7 years ago

No problem here under Linux!
I did some tests on SHP with 20000 selected records! slightly slows, but it was expected this behavior!

#5 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Open to Feedback

Cannot confirm, tested on qgis-master, windows 7 and a 200000+ records table. It is pretty slow (but my VM has just a little cpu and ram) but no crash. Can you try another pc and/or dataset?

#6 Updated by Giovanni Manghi over 7 years ago

just tested with your dataset and no crash

#7 Updated by Filipe Dias over 7 years ago

It stills crashes here, even after a clean installation. If no one else experiences this, it must be a local problem.

#8 Updated by Filipe Dias over 7 years ago

Just tested on a second machine (clean installation of both Windows and QGIS), with the same dataset and this still happens.

Does anyone have an idea of what might be going on? Thks

#9 Updated by Pieter Roggemans over 7 years ago

Just tested this with a file of +- 130.000 features and selecting +- 32.000 of them QGIS doesn't strictly crash, but becomes and stays unresponsive for hours... so I killed it.

Tested on Windows 7 64 bit, by selecting all features with OPP > 10 in this shape file:
https://docs.google.com/open?id=0B-lmgiUm-f0HRWpadzZpNlk4cmM

#10 Updated by Paolo Cavallini about 7 years ago

  • Target version set to Version 2.0.0

#11 Updated by Giovanni Manghi almost 7 years ago

  • Status changed from Feedback to Open
  • Operating System deleted (Windows 7)

#12 Updated by Regis Haubourg over 6 years ago

I confirm that QGIS becomes slow when dealing with selections. I tested with around 2000 features selected on 36000 (polygons) and QGIS become unresponsive when dealing with attribute table. ressources consumption seems on CPU more than on memory.
My guess is that the way QGIS draws selected features is not efficient. I saw similar behaviour with highlight of identified features when they are very complex.
It's works on 1.8 but is slow. When trying to check 'selected only', I saw a redraw triggered on mapcanvas. This certainly slow things down, but is not the only problem. I vote to switch to blocker that issue (regression and unusability).

#13 Updated by Giovanni Manghi over 6 years ago

  • Priority changed from High to Severe/Regression

regis Haubourg wrote:

I vote to switch to blocker that issue (regression and unusability).

I agree, I'll take the risk to have a dev blame me for this, but even if this issue is not strictly a regression is a huge usability issue.

The same applies to the "identify" ticket, than right now I cont' find. The issue is the described here, if a feature is complex (many nodes) the features makes qgis completely non responsive. Regis if you know the ticket about the identify issue please raise its priority (if it not already a blocker).

#14 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF