Bug report #5486

SRS error for new SpatiaLite layer in old SL DBs

Added by Paolo Cavallini over 8 years ago. Updated over 8 years ago.

Status:Closed
Priority:Normal
Assignee:Giuseppe Sucameli
Category:Data Provider
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:15104

Description

When creating a new Spatialite vector, selecting a SRS results in an error:

Impossible to load SRIDS: no such table: spatial_ref_sys

No problem with shp. Master from yesterday.

History

#1 Updated by Giovanni Manghi over 8 years ago

  • Priority changed from Normal to Severe/Regression

This should affect also the code frozen for the 1.8 release, so I'll tag this as blocker as is a regression.

#2 Updated by Jürgen Fischer over 8 years ago

Is the real message "Failed to load SRIDS"?

#3 Updated by Paolo Cavallini over 8 years ago

Yes, it was my dummy backtranslation from the IT GUI.The real message is:

Failed to load SRIDS: no such table: spatial_ref_sys

as you guessed.
Sorry.

#4 Updated by Marco Hugentobler over 8 years ago

I can create a new spatialite layer without SRS problem (master branch from today). Is the ticket still valid?

#5 Updated by Paolo Cavallini over 8 years ago

Just checked, with today's master, same error.
Self packaged on Debian testing with master debian/rules

#6 Updated by Giovanni Manghi over 8 years ago

works fine on ubuntu 11.04 and qgis master from the nightly build repo.

#7 Updated by Salvatore Larosa over 8 years ago

same here on Debian/wheezy and QGIS master (173e9ad), everything works fine!

#8 Updated by Marco Hugentobler over 8 years ago

  • Status changed from Open to Closed

Looks like a package problem to me then.

#9 Updated by Paolo Cavallini over 8 years ago

  • Subject changed from SRS error for new SpatiaLite layer to SRS error for new SpatiaLite layer in old SL DBs
  • Assignee set to Giuseppe Sucameli
  • Status changed from Closed to Reopened
  • Category changed from Projection Support to Data Provider

It was not due to compilation, but to a change in SL provider, I think: spatial_ref_sys of old SL db are not recognized. This could be a bug in itself.

#10 Updated by Paolo Cavallini over 8 years ago

  • Priority changed from Severe/Regression to Normal

#11 Updated by Giuseppe Sucameli over 8 years ago

Unable to reproduce it. Probably the problem depends on the used database (old or what?).
Could you provide a small dataset to reproduce it?

#12 Updated by Paolo Cavallini over 8 years ago

See subject and comment #9: yes, this is due to old DBs

#13 Updated by Giuseppe Sucameli over 8 years ago

  • Resolution set to invalid
  • Status changed from Reopened to Closed

Probably that db has no spatial_ref_sys table and then it's an invalid SL database.

Also available in: Atom PDF