Feature request #5426

selected objects should go to top level

Added by aperi2007 - over 5 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Canvas
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No

Description

In qgis-dev 3147836.
When a layer has more object overlapped each-other.
Selecting one element using the table.
The selected element is colored yellow.
But if it is not on top of overlapped element it is not visible.
The selected elements (one or more) should always go on top of the layer, this will help it use.

History

#1 Updated by aperi2007 - over 5 years ago

Perhaps a good solution should be to add to qgis a "phantom layer" always on top of the other layers.
This phantom layer is not accessible from legend.
But it is fill only with eventually selected geometries from others layer.
When the user click on "deselect geometries" the phantom layer is clean.

#2 Updated by Paolo Cavallini about 5 years ago

  • Target version set to Version 2.0.0

#3 Updated by Pirmin Kalberer about 5 years ago

  • Target version changed from Version 2.0.0 to Future Release - Nice to have

#4 Updated by Melissa Nunes over 3 years ago

I would rank this higher than 'nice to have'. Not being able to see selections over other features in the same layer makes QGIS not very useful in QAing my data entry. Thanks!

#5 Updated by Médéric RIBREUX almost 2 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Hello, bug triage...

this is a duplicate of #5411.

I am closing it !

Also available in: Atom PDF