Bug report #5328

SPIT - Geometry type does not match column type

Added by Salvatore Larosa over 7 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:C++ Plugins
Affected QGIS version:master Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:15029

Description

If I use the SPIT plugin to import polygon features in PostGIS I get this:

ERROR:  Geometry type (Polygon) does not match column type (MultiPolygon)

Also, if I import line features I get:
ERROR:  Geometry type (LineString) does not match column type (MultiLineString)

PostGIS version:
"POSTGIS="2.0.1SVN r9614" GEOS="3.3.3-CAPI-1.7.4" PROJ="Rel. 4.7.1, 23 September 2009" GDAL="GDAL 1.9.0, 
released 2011/12/29" LIBXML="2.7.8" TOPOLOGY RASTER" 

Unfortunately, #5109 did not solve this problem!

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Open to Feedback

SPIT is not maintained and it will be discontinued/removed when DB Manager will allow multiple shape upload. I think that any ticket on this tool is then not "necessary".

#2 Updated by Paolo Cavallini about 7 years ago

  • Target version set to Version 2.0.0

#3 Updated by Giovanni Manghi about 5 years ago

  • Resolution set to wontfix
  • Status changed from Feedback to Closed

I guess we can really close this, also because we can import vectors in batch mode using Processing.

Also available in: Atom PDF