Bug report #5284

MS SQL features disappear if SQL errors on insert

Added by Nathan Woodrow over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:High
Assignee:Tamas Szekeres
Category:Data Provider
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:15004

Description

If you are saving a feature and the database fails to insert due to a SQL error the feature will disappear with no error to tell the user what has happened.

The PostGIS provider throws a error and blocks the save operation until the user has fixed the mistake, letting the user try to save again after the changes have been made.


Related issues

Related to QGIS Application - Bug report #5283: MS SQL provider doesn't save data or datetime Closed

History

#1 Updated by Nathan Woodrow over 9 years ago

  • Parent task deleted (#5283)
  • Subject changed from Features disappear if SQL errors to MS SQL features disappear if SQL errors on insert

#3 Updated by Jürgen Fischer over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Also available in: Atom PDF