Bug report #5258

WMS layer properties should be updated upon visiting the 'layer properties' dialog

Added by Ricardo Silva over 7 years ago. Updated 9 months ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:No Copied to github as #:14992

Description

I have a WMS server that is changing its data on an hourly basis and I'd like to always know what data is being shown. As it stands now, the 'wms_abstract' property of the layer is my best option to figure out what I am visualizing.

However, when I open the 'layer properties' dialog, QGIS is refreshing the layer's imagery (which is kinda wierd, see bug #4947), but not the actual layer properties. Currently the layer properties only get refreshed if I remove the layer and load it again.

History

#1 Updated by Paolo Cavallini about 7 years ago

  • Target version set to Version 2.0.0

#2 Updated by Giovanni Manghi about 7 years ago

  • Status changed from Open to Feedback

Hi Ricardo, is qgis 1.8 and/or master still affected?

#3 Updated by Giovanni Manghi about 6 years ago

  • Affected QGIS version changed from 1.7.4 to 2.0.1
  • Status changed from Feedback to Open
  • Target version changed from Version 2.0.0 to Future Release - High Priority

#4 Updated by Médéric RIBREUX almost 4 years ago

Hello, bug triage...

seems to be still true for QGIS 2.13. Perhaps should we add a refresh button on metadata tab to explicitly refresh metadata ?

#5 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to No
  • Easy fix? set to No

#6 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

Please test with a recent QGIS release (2.18 or 3), if the issue/request is still valid change the affected version accordingly, if is fixed/implemented then close the ticket. Thanks!

#7 Updated by Jürgen Fischer 9 months ago

  • Resolution set to no timely feedback
  • Description updated (diff)
  • Status changed from Feedback to Closed

Also available in: Atom PDF