Bug report #5225

Error for labeling with rule based renderer

Added by Otto Dassau over 7 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Labelling
Affected QGIS version:1.7.4 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:14961

Description

Hi,

I have a point shape layer with street names. The field 'name' often only contains the word "Weg" and I don't want to see this on the map.

If I select categorized rendering based on column 'name' and remove the category "Weg", the points and labels for "Weg" are invisible - fine.

If I use rule-based rendering with the filter NOT name = 'Weg', the points for "Weg" are invisible, but I can still see the labels. Since I want to use the rule-based renderer, can someone tell, if this is a bug or if I do something wrong? Attached you find a test shape file to reproduce.

Thanks a lot
Otto

error_rule_based_labeling.zip (1.87 KB) Otto Dassau, 2012-03-23 07:06 AM

History

#1 Updated by Otto Dassau over 7 years ago

  • Affected QGIS version changed from master to 1.7.4
  • Target version set to 35

#2 Updated by Giovanni Manghi over 7 years ago

  • Target version changed from 35 to Version 1.8.0

#3 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Giovanni Manghi about 6 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

seems fixed, at least in qgis 2.0.

Also available in: Atom PDF