Bug report #5008

Map canvas flicker when qgis window gains/losts focus or on mouse enter/exit the canvas

Added by Gabriele Monfardini over 8 years ago. Updated about 8 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:14785

Description

The flickering happens when:

  • qgis window grabs/losts the focus
  • mouse enters/exits map canvas but ONLY if qgis window does not have the focus

I'm on git master up-to-date (2011-02-14) (last commit 1dfc3b7a293c40f3d10386cc620dee2322dd152b).

Versione di QGIS 1.9.90-Alpha
QGIS code revision 2cea349
Compiled against Qt 4.7.4
Running against Qt 4.7.4
GDAL/OGR Version 1.9.0
GEOS Version 3.4.dev
PostgreSQL Client Version 9.1.2
SpatiaLite Version 2.4.0
QWT Version 5.2.2

There is no log from QGIS, no log from Xorg, nor entries in syslog.
Toggling the checkbox "Update" does not have any effect, so flickering is not due to updating the view.

My video card is a Radeon HD 3450, with radeon driver.
I'm on kubuntu 11.10 running kde.

Toggling desktop effects in my desktop manager (kdm) does not have any effects.
Toggling compositing type from OpenGL and Xrender does not have any effects.

It is probably related to issue #4011


Related issues

Related to QGIS Application - Bug report #3771: White stripes when panning map Closed 2011-07-25
Related to QGIS Application - Bug report #4011: Map canvas flickers when content is dragged Closed 2011-06-22

History

#1 Updated by Matthias Kuhn about 8 years ago

  • Status changed from Open to Closed

Fixed.
See #4011

Also available in: Atom PDF