Bug report #4913

QGIS freezes when pasting text into the field calculator new expression builder

Added by Giovanni Manghi over 8 years ago. Updated over 8 years ago.

Status:Closed
Priority:Normal
Assignee:Nathan Woodrow
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:Yes Copied to github as #:14720

Description

On master I'm noticing the following:

if I open the field calculator and I try to paste text into the expression builder (copied from an external application, like gedit or evolution), then QGIS freezes. Sometimes it regain life after a few minutes, more often it stops completely, cpu at 100% and killing the program is the only way out.

teste1_shp.zip (67.3 KB) Giovanni Manghi, 2012-01-30 06:09 AM

History

#1 Updated by Giovanni Manghi over 8 years ago

  • Assignee changed from neteler-itc-it - to Nathan Woodrow

Actually I'm also noticing that is freezing by just doing simple things as adding a function. Not sure at this point is a local problem or not. I'll test more and close this ticket if it turns out to be invalid.

#2 Updated by Giovanni Manghi over 8 years ago

weird, it does certainly happen with the attached vector.

#3 Updated by Nathan Woodrow over 8 years ago

hmm very strange. Seems it's related to the syntax highlighting. If I get rid of the highlighting it doesn't lock up. Other data sets don't have this behavior.

#4 Updated by Martin Dobias over 8 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed in f854acb1

btw. Giovanni your shapefile has a column without a name :)

#5 Updated by Giovanni Manghi over 8 years ago

btw. Giovanni your shapefile has a column without a name :)

yes, it is another problem of the new field calculator (I already filed a ticket).

Also available in: Atom PDF