Bug report #4876

Editing a shapefile - 2 regressions from early December 2011.

Added by Benoit de Cabissole over 8 years ago. Updated over 8 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:14701

Description

New problems with editing shapefiles that were not present in the early December 2011 QGIS master versions (sorry for not being more specific).

To reproduce:

1) Add a node
- Open a polygon shapefile.
- Select the "node tool".
- Double-click a segment to add a node at that location.
=> The node is created, but there is no way to access it! (This is a regression from previous versions)
There are a few tedious workarounds to that, but none are satisfactory.

2) Select a node
- Open a polygon shapefile.
- Select the "node tool".
- Try to select and move a single node.
=> More often than not a segment is selected instead of the node (even if the node is clicked right on its centre), resulting in moving the segment instead of the node.
Again, this seems to be a regression from previous versions.

QGIS settings are:
- Search radius for vertex edits: 10 pixels (default)
Tried to increased to 20 pixels: no improvements.
- Default snapping tolerance: 0.
- No snapping used on layer.
- Validate geometries: tried with QGIS on and off. Same results.

Can those two regressions be confirmed?

History

#1 Updated by Giovanni Manghi over 8 years ago

  • Status changed from Open to Feedback

Just updated to master.

a) not confirmed

b) not confirmed

please update to the lastest version, try again and report back.

#2 Updated by Benoit de Cabissole over 8 years ago

  • Resolution set to fixed
  • Priority changed from Normal to Low
  • Status changed from Feedback to Closed

Hello Giovanni.
You are correct. The latest OSGEO4W build, downloaded today, does not show those behaviours anymore.
I closed the ticket and sorry for the noise...
Benoit

Also available in: Atom PDF