Bug report #4845

Hardcoded Encodings

Added by magerlin - almost 8 years ago. Updated over 7 years ago.

Status:Rejected
Priority:Normal
Assignee:Maxim Dubinin
Category:Python plugins
Affected QGIS version:master Regression?:No
Operating System:Win Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:14682

Description

This is a "prayer" for the plugin programmers!

First of all thank you for your contributions!

Qgis in it self is able to read and save shapefiles with many different encodings, but some plugins seems to be hardcoded saving files in a specific encoding.

One example is the ShapeFileSplitter. Even if I give an ISO8859-15 encoded shapefile as input the resulting splitted files are in UTF-8. And it is a bit troublesome when working with national characters.

I fully support another thread suggesting adding a .cpg file for storing the encoding!

History

#1 Updated by Paolo Cavallini almost 8 years ago

  • Resolution set to invalid

Please move this ticket to the appropriate plugin subproject. Also, this should be added to the plugin howto (i.e. the cookbook).

#2 Updated by Jürgen Fischer over 7 years ago

  • Status changed from Open to Rejected

Also available in: Atom PDF