Bug report #48

GRASS Digit: attribute window moves around not asked to

Added by werchowyna-epf-pl - about 14 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Redmine Admin
Category:GRASS
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10107

Description

Please prevent the attribute window from jumping around
- it often jumps to the most top-left location,
covering the layer tree and forcing me to move it back
from there to the location of my choice; then it will
jump back to cover the layer tree...

Maciek

History

#1 Updated by Redmine Admin about 14 years ago

Is it still true?
Is it realy related to QGIS, was not it window manager problem?
I could never reproduce such a behaviour.
Does it happen also with current HEAD version?

Radim

#2 Updated by maciek - about 14 years ago

Yes, with 0.7.4 SVN about 3 weeks old.

Is it realy related to QGIS, was not it window manager problem?

Dunno. Using Ubuntu Breezy with GNOME.

I could never reproduce such a behaviour.

KDE?

Does it happen also with current HEAD version?

Haven't tried due to lack of QT 4.1. For Breezy only QT 4.0 is
packaged, which I heard is problematic with QGIS 0.7.9.

What do I do in order to install QT 4.1 on Breezy without hacking too
much? I wouldn't mind building from source unless it is fairly
straightforward. Having qt 4.1 I could help with testing.

Maciek

#3 Updated by Redmine Admin about 14 years ago

On 4/4/06, Maciek Sieczka <> wrote:

Yes. Easy to reproduce:

1. Open a Grass vector.
2. Pick "Edit table".

Do you mean 'Edit attributes'?

3. Left click some object.
4. Table pops up. Edit it as needed, move to lower-right corner.
5. Click another object. All fine. Click another one - and the table
jumps to top right corner. Bad table.

Sorry, I have no idea, the position is stored whenever the attributes
dialog is closed (deleted) and restored when a new one is created
(another element selected).
Do you have the same problem when new elements are digitized?

BTW: I have maybe similar problem with edit region dialog,
move() is called but somehow ignored.

Radim

#4 Updated by Redmine Admin about 14 years ago

I added debug output. Whenever you select an element
you should see in terminal something like

[[QgsGrassAttributes]]()
[[QgsGrassAttributes]]::restorePosition()
wx = 200 wy = 406

The values are then used in move(wx,wy); to set windows position.
Check if these values are correct.

Radim

#5 Updated by Redmine Admin about 14 years ago

Please try with fresh SVN. I have changed widget style
and it could work. I think that the problem was that certain
widget styles calls adjustSize after move.

I have also changed it so that the window is not closed always
when a new element is selected, that should make it more pleasant.

Radim

#6 Updated by Redmine Admin almost 14 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Fixed in 0.8.

Radim

#7 Updated by Anonymous over 10 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF