Bug report #4753

A layer only becomes visible if it is selected

Added by Vasco Nunes over 7 years ago. Updated about 6 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Map Legend
Affected QGIS version:1.7.3 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:14622

Description

If you're working with several layers and you need to turn visibility on and off in different layers, currently you need the layer you want to turn visible/invisible to be selected, i.e. you need to first select the layer and then tick the checkbox. It would save some time and clicks for users if the selecting step wouldn't be necessary.

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Priority changed from Normal to Low
  • Category set to Map Legend
  • Status changed from Open to Feedback

Olá Vasco,

what desktop manager/OS do you use? I'm asking because selecting the layer before clicking on the checkbox is not necessary on both my Linux/Gnome and Windows systems (at least on qgis-master). Please leave feedback.

#2 Updated by Vasco Nunes over 7 years ago

I use Windows7. Check this: http://youtu.be/wAXUdnemCP0
The problem is that sometimes it works fine and sometimes it doesn't. My it is worse when i have more layers loaded.

#3 Updated by Giovanni Manghi over 7 years ago

Vasco Nunes wrote:

I use Windows7. Check this: http://youtu.be/wAXUdnemCP0
The problem is that sometimes it works fine and sometimes it doesn't. My it is worse when i have more layers loaded.

a few changes have been made to TOC/legend in the past weeks, can you please give it a go on qgis-master (using osgeo4w) and report back? thanks.

#4 Updated by Paolo Cavallini about 7 years ago

  • Target version set to Version 2.0.0

#5 Updated by Giovanni Manghi about 6 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

seems fixed to me, at least on qgis 2.0.

Also available in: Atom PDF