Bug report #4720

cfloat32/64 or cint16/32 rasters do not show in QGIS canvas

Added by Giovanni Manghi over 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Rasters
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:14601

Description

The attached raster was first imported into GRASS then exported with r.out.gdal as cfloat32/geotiff.

The result freezes QGIS when adding it to a project.

cfloat32.tif.tar.gz (283 KB) Giovanni Manghi, 2011-12-30 06:31 AM

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Subject changed from opening a cfloat32 raster freezes QGIS to opening a cfloat32/64 or cint16/32 raster freezes QGIS

Same happens with cfloat64 and cint16/32

#2 Updated by Giovanni Manghi over 7 years ago

  • Priority changed from 6 to High

#3 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#4 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#5 Updated by Giovanni Manghi almost 7 years ago

  • Subject changed from opening a cfloat32/64 or cint16/32 raster freezes QGIS to cfloat32/64 or cint16/32 rasters do not show in QGIS canvas
  • Crashes QGIS or corrupts data changed from Yes to No
  • Priority changed from High to Low

No more freezes in qgis master, but the rasters do not show in canvas. In raster properties the stats seems to be correctly computed as are histograms.

#6 Updated by Giovanni Manghi almost 7 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

Not supported formats. The suggested solution is o remove the options that allow to obtain that outputs from the r.out.gdal module in the GRASS plugin.

Also available in: Atom PDF