Bug report #4717

Rotation affects offset direction

Added by Paolo Cavallini over 7 years ago. Updated over 1 year ago.

Status:Closed
Priority:Low
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:14598

Description

When a rotation is applied to a symbol, the offset is no longer orthogonal, but along rotated axes. Keeping it orthogonal seems a more sound choice to me.

4717_master.diff Magnifier - Patch for fix. (2.07 KB) JD -, 2012-01-16 09:43 AM

History

#1 Updated by JD - over 7 years ago

Fixed by removing _rotatedOffset() function which was applying the rotation value to the symbol's centre point. Patch attached.

Also fixed default arrow symbol which wasn't symmetrical.

#2 Updated by Giovanni Manghi over 7 years ago

  • Pull Request or Patch supplied changed from No to Yes

#3 Updated by Marco Hugentobler over 7 years ago

  • Assignee set to Martin Dobias

#4 Updated by Martin Dobias over 7 years ago

Please describe me your use case. For me the current handling seems correct: imagine that you have a symbol composed of several layers, some of them having an offset. When I start rotating the whole symbol, the offset direction must be rotated too - otherwise the symbol appearance would break. Or do you mean something else?

#5 Updated by Paolo Cavallini over 7 years ago

Quite convincing. However, in case of a single symbol, probably an user will want to use rotation and offset independently.

#6 Updated by Paolo Cavallini about 7 years ago

  • Target version set to Version 2.0.0

#7 Updated by Martin Dobias over 5 years ago

  • Assignee deleted (Martin Dobias)
  • Target version changed from Version 2.0.0 to Future Release - Nice to have

#8 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to No
  • Easy fix? set to No

#9 Updated by Paolo Cavallini over 1 year ago

  • Resolution set to wontfix
  • Status changed from Open to Closed
  • Priority changed from Normal to Low

Well, it's an edge case. Since nobody seems interested, we can assume the current behaviour is acceptable to users.

Also available in: Atom PDF