Bug report #4664

Above/below labels for vertical up-to-down line swapped

Added by Sandro Santilli almost 8 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:Martin Dobias
Category:Labelling
Affected QGIS version: Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:14556

Description

I can't find the commit that fixed this in master but the bug is about Above/Below not properly becoming Right/Left for a top-down vertical line.
It works fine in master. I believe 627d25c65f7438541243b9974027f4ceb00d2cc9 was pushed close to the commit actually fixing the issue.

It would be worth following ticket 3643 and testing if one of those patches would fix this.
The whole thing, once found, should be back-ported to 1.7 branch. Ideally regress-tested.

Martin: I'm assigning to you as you were most likely the one fixing it in master so you may have a better idea of which commit did it.
Thanks!

History

#2 Updated by Sandro Santilli almost 8 years ago

Ok,found the commit fixing this:
c37b63a83f9d72223f375a490c6555f0c9c2a015

That's the one I'd like to see in 1.7.4 :)

#3 Updated by Sandro Santilli almost 8 years ago

I just double-checked and I can double-confirm c37b63a83f9d72223f375a490c6555f0c9c2a015 is the one

#4 Updated by Werner Macho almost 8 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

picked it into release-1_7 for upcoming 1.7.4

Also available in: Atom PDF