Bug report #4655

Plugin installer fails to detect invalid repository urls

Added by Sandro Santilli almost 8 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:Borys Jurgiel
Category:Python plugins
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:14553

Description

As of plugin_installer 1.2.1 (qgis 1.7.3) invalid repository urls are not signaled to user, although there seems to be code meant to do that.
For invalid I mean urls pointing to HTML, for example, as it was the case in a development snapshot of qgis listing "http://plugins.qgis.org/plugins" as an official repository url.

See #4621 for the effects of such feedback lack (confusion...)

History

#1 Updated by Borys Jurgiel almost 8 years ago

  • Assignee set to Borys Jurgiel

#2 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.3 to Version 1.7.4

#3 Updated by Paolo Cavallini over 7 years ago

  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0

#4 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#5 Updated by Borys Jurgiel about 6 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Fixed in 86bebab and following.

Also available in: Atom PDF