Bug report #4654

plugin_installer: drop "Only show plugins from the official repository" option

Added by Sandro Santilli almost 8 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:Borys Jurgiel
Category:Python plugins
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:14552

Description

The "Only show plugins from the official repository" option in the "Options" tab of the plugin_installer duplicates functionality already available as a filter in the "Plugins" tab. This is very confusing as you think you're seeing plugins from "all repositories" (the filter says) but instead you're restricted to official repository only due to that option checked in a tab you don't see in front of you.

This confusion made me waste a couple of hours trying to debug issue #4621

It'd be nice to see this fixed in 1.7 branch too.

I'm missing Target version 1.7.4 here :)
Maybe easier to add a Target version 1.7 ?

History

#1 Updated by Borys Jurgiel almost 8 years ago

  • Assignee set to Borys Jurgiel

#2 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.3 to Version 1.7.4

#3 Updated by Paolo Cavallini over 7 years ago

  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0

#4 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#5 Updated by Borys Jurgiel over 6 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Also available in: Atom PDF