Bug report #4645

Changing multiple symbol colours at once is applied immediately to the layer

Added by Tim Sutton over 8 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:14543

Description

When dealing with categorised or ramp new symbology, you can select multiple classes and change their colour in one operation. However if the user presses cancel on the vector layer properties dialog, these changes are applied anyway. This is bad....

History

#1 Updated by Paolo Cavallini over 7 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.8.0 to Version 2.0.0
  • Affected QGIS version set to master

#2 Updated by Jürgen Fischer almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#3 Updated by Médéric RIBREUX over 4 years ago

  • Status changed from Open to Feedback

Hello, bug triage...

seems to be fixed (at least in master). If I cancel the changes, the style is not updated.

Can you confirm this ?

#4 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

seems really fixed now, please reopen if necessary.

Also available in: Atom PDF