Bug report #4540

Garbled field names in newly created Shapefiles

Added by kouichi kita about 8 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:14456

Description

In QGIS 1.7.1, when I have created a new shapefile with Japanese characters on the field names, the field names are garbled.
This is because field names are written in UTF-8, but values are written in Shift_JIS, I think.
(The rest is omitted. Here Shift_JIS is the same as the selected encoding.)


Related issues

Related to QGIS Application - Feature request #6059: add the ability to select character code when creating a ... Closed 2012-07-17

Associated revisions

Revision 788e4294
Added by Minoru Akagi over 6 years ago

write field names in the same encoding as attribute values (fix #4540)

Revision 94a976c9
Added by Borys Jurgiel over 6 years ago

Merge pull request #578 from minorua/fieldname_encoding

write field names in the same encoding as attribute values (fix #4540)

History

#1 Updated by Giovanni Manghi about 8 years ago

  • Status changed from Open to Feedback

Please file the tickets in English :)

#2 Updated by Richard Duivenvoorde about 8 years ago

pfoo, this is what Google Translate makes of it... not very clear yet. But I think we need someone able to check this on a japanese system.

In QGIS Ver1.7.1, when creating a new shapefile, use the Japanese garbled on the field name.
This is the field name "UTF-8" are created in the data is "Shift JIS" you think because it is created.
When you add a vector layer "encoding" the "System" occurs when the.

In 1.6.0, I think that was the field names are displayed instead of garbled.

#3 Updated by Paolo Cavallini almost 8 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Please translate it in English (including the title) and reopen it.

#4 Updated by Minoru Akagi over 6 years ago

  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No
  • Status changed from Closed to Reopened

Translation:

[Title] Garbled field names in newly created Shapefiles

In QGIS Ver.1.7.1, when I have created a new shapefile with Japanese characters on the field names, the field names are garbled.
This is because field names are written in UTF-8, but values are written in Shift_JIS, I think.
(The rest is omitted. Here Shift_JIS is the same as the selected encoding.)

#5 Updated by Minoru Akagi over 6 years ago

(This causes corruption.)
A patch for this is on #6059.

#6 Updated by Jürgen Fischer over 6 years ago

  • Subject changed from 新しいシェープファイルを作るときのフィールド名の文字化け to Garbled field names in newly created Shapefiles

#7 Updated by Borys Jurgiel over 6 years ago

  • Status changed from Reopened to Closed

#8 Updated by Borys Jurgiel over 6 years ago

  • Resolution changed from invalid to fixed

Also available in: Atom PDF