Bug report #4521

Map Tips does not work with on the fly CRS transformation

Added by alobo - almost 8 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System:all Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:14439

Description

Map tips do not show up if a given layer has a different CRS than the project with
on the fly CRS transformation activated.
Agus

maptips.patch Magnifier (1.21 KB) Victor Axbom, 2012-05-15 11:43 PM

Associated revisions

History

#1 Updated by Giovanni Manghi almost 8 years ago

In my qgis-master installation maptips are broken regardless the CRS of the layer, the CRS of the project or if OTFR is enabled.

#2 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.2 to Version 1.7.3

#3 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.3 to Version 1.7.4

#4 Updated by Paolo Cavallini over 7 years ago

  • Crashes QGIS or corrupts data set to No
  • Priority changed from 6 to Normal
  • Affected QGIS version set to master

#5 Updated by Thaddeus - over 7 years ago

This is still not working on my QGIS version 1.7.4 Wroclaw: only works if on-the-fly CRS is off or set the same as data source ?

#6 Updated by Thaddeus - over 7 years ago

The Hotlink plug-in suffers the same fate: ¿ would this be related or a different ticket ?

#7 Updated by Thaddeus - over 7 years ago

MapTips also displays the message "Maptips require an active layer" after user has selected a layer: the warning message should be reset (disappear) the instant user selects a layer. Tested on Win2k and QGIS1.7.4.

#8 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#9 Updated by Victor Axbom over 7 years ago

Submitting a patch for this issue. But please review it carefully since I'm new both to C++ and Qgis core programming and this is my first attemp to contribute to the project. I tried to follow the qgis coding conventions, but I might have forget something.

#10 Updated by Marco Hugentobler over 7 years ago

  • Pull Request or Patch supplied changed from No to Yes

#11 Updated by Jürgen Fischer over 7 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF