Bug report #4413

Generating SVG preview takes very long

Added by Paolo Cavallini almost 10 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:14345

Description

When adding an image to a print layout, the generation of preview from SVG takes a very long time

History

#1 Updated by Marco Hugentobler almost 10 years ago

Well, the tmore preview directories / files you have, the longer it takes (with only the standard svg dirs enabled, it takes 2 seconds for me here). But the preview generation is postponed until the item dialog shows up and additionally, it is possible to cancel loading of previews.

#2 Updated by Paolo Cavallini almost 10 years ago

Wouldn't it be more appropriate to generate the previews during compilation? In my case it takes several minutes to generate them all, and I suspect things can only get worse as people use more and more symbols. BTW, I think we should organize symbols in groups/tags/folders, otherwise they will be more and more difficult to use.

#3 Updated by Giovanni Manghi over 9 years ago

  • Target version set to Version 1.7.4

#4 Updated by Paolo Cavallini over 9 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#5 Updated by Paolo Cavallini almost 9 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#6 Updated by Jürgen Fischer over 7 years ago

  • Category changed from 33 to Map Composer/Printing

#7 Updated by Jürgen Fischer about 7 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#8 Updated by Médéric RIBREUX over 5 years ago

  • Status changed from Open to Feedback

Hello, bug triage...

it seems to be fixed in QGIS 2.13, when I add an image in the composer, the search directories groupbox is displayed nearly instantly.

Could we close this bug ?

#9 Updated by Paolo Cavallini over 5 years ago

Sorry, I have a very fast machine here, cannot test properly.

#10 Updated by Médéric RIBREUX over 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

Hello, bug triage...

it needs about 3 seconds on a low CPU (AMD A4-5000 1.5 GHz) to be displayed.

I am closing this bug...

Also available in: Atom PDF