Bug report #4303

Plugin installer: error if high-ASCII in path

Added by Paolo Cavallini almost 8 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Python plugins
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:14240

Description

If in the path there is some high-ASCII, the installer throws an error, and plugins cannot be installed. Looks an easy fix. Details below.
Thanks.

No se pudo cargar el complemento 'ziplayers' de
['C:/PROGRA~2/QUANTU~1/apps/qgis-dev/./python', 'C:/Users/Marí
a/.qgis/python', 'C:/Users/María/.qgis/python/plugins',
'C:/PROGRA~2/QUANTU~1/apps/qgis-dev/./python/plugins', 'C:\\PROGRA~2
\\QUANTU~1\\bin\\python25.zip', 'C:\\PROGRA~2\\QUANTU~1\\apps\\Python25
\\DLLs', 'C:\\PROGRA~2\\QUANTU~1\\apps\\Python25\\lib', 'C:\\PROGRA~2
\\QUANTU~1\\apps\\Python25\\lib\\plat-win', 'C:\\PROGRA~2\\QUANTU~1\\apps
\\Python25\\lib\\lib-tk', 'C:\\PROGRA~2\\QUANTU~1\\apps\\qgis-dev\\bin', 'C:
\\PROGRA~2\\QUANTU~1\\apps\\Python25', 'C:\\PROGRA~2\\QUANTU~1\\apps\\Python25
\\lib\\site-packages', 'C:\\PROGRA~2\\QUANTU~1\\apps\\Python25\\lib
\\site-packages\\win32', 'C:\\PROGRA~2\\QUANTU~1\\apps\\Python25\\lib
\\site-packages\\win32\\lib', 'C:\\PROGRA~2\\QUANTU~1\\apps\\Python25\\lib
\\site-packages\\Pythonwin', 'C:\\PROGRA~2\\QUANTU~1\\apps\\qgis-dev\\python
\\plugins\\fTools\\tools']

Traceback (most recent call last):
File "C:/PROGRA~2/QUANTU~1/apps/qgis-dev/./python\\qgis\\utils.py",
line 117, in loadPlugin
import(packageName)
File "C:/PROGRA~2/QUANTU~1/apps/qgis-dev/./python\\qgis\\utils.py",
line 283, in _import
mod = _builtin_import(name, globals, locals, fromlist, level)
ImportError: No module named ziplayers

Versión de Python:
2.5.2 (r252:60911, Feb 21 2008, 13:11:45) [MSC v.1310 32 bit (Intel)]

Versión de QGIS:
1.8.0-Trunk Trunk, a4c2180

Ruta de Python: ['C:/PROGRA~2/QUANTU~1/apps/qgis-dev/./python',
'C:/Users/Mar\\xc3\\xada/.qgis/python', 'C:/Users/Mar\\xc3
\\xada/.qgis/python/plugins',
'C:/PROGRA~2/QUANTU~1/apps/qgis-dev/./python/plugins', 'C:\\\\PROGRA~2\\
\\QUANTU~1\\\\bin\\\\python25.zip', 'C:\\\\PROGRA~2\\\\QUANTU~1\\\\apps\\\\Python25
\\\\DLLs', 'C:\\\\PROGRA~2\\\\QUANTU~1\\\\apps\\\\Python25\\\\lib', 'C:\\\\PROGRA~2\\
\\QUANTU~1\\\\apps\\\\Python25\\\\lib\\\\plat-win', 'C:\\\\PROGRA~2\\\\QUANTU~1\\
\\apps\\\\Python25\\\\lib\\\\lib-tk', 'C:\\\\PROGRA~2\\\\QUANTU~1\\\\apps\\\\qgis-dev
\\\\bin', 'C:\\\\PROGRA~2\\\\QUANTU~1\\\\apps\\\\Python25', 'C:\\\\PROGRA~2\\
\\QUANTU~1\\\\apps\\\\Python25\\\\lib\\\\site-packages', 'C:\\\\PROGRA~2\\
\\QUANTU~1\\\\apps\\\\Python25\\\\lib\\\\site-packages\\\\win32', 'C:\\\\PROGRA~2\\
\\QUANTU~1\\\\apps\\\\Python25\\\\lib\\\\site-packages\\\\win32\\\\lib', 'C:\\
\\PROGRA~2\\\\QUANTU~1\\\\apps\\\\Python25\\\\lib\\\\site-packages\\\\Pythonwin',
'C:\\\\PROGRA~2\\\\QUANTU~1\\\\apps\\\\qgis-dev\\\\python\\\\plugins\\\\fTools\\
\\tools']

homePythonPath.diff Magnifier (558 Bytes) Minoru Akagi, 2013-04-07 04:24 AM

update-homePythonPath.patch Magnifier (952 Bytes) Minoru Akagi, 2013-04-07 06:34 AM


Related issues

Related to QGIS Application - Bug report #4141: Problem installing plugins Closed 2011-08-05
Duplicated by QGIS Application - Bug report #6746: Plugin installation fails when username contains accents Closed 2012-11-21
Duplicated by QGIS Application - Bug report #7488: Reading plugins from path with accented characters doesn'... Closed 2013-04-02

Associated revisions

History

#1 Updated by Borys Jurgiel almost 8 years ago

Does the installer display any "gentle" error message prior to raising the error? It seems the plugin was successfully installed, but then qgis.utils fails to load it. Could you please look to the plugins directory and check if the plugin is there? If it's present, then the problem is in qgis.utils, otherwise in the installer.

#2 Updated by Paolo Cavallini almost 8 years ago

I no longer have a access to the win machines that threw the error. AFAIR:
  • no gentle error message
  • the plugin is there, just not loaded

#3 Updated by Borys Jurgiel almost 8 years ago

Ok, than it's related to Python plugins paths, not to the installer.
Unfortunately also I have no access to an affected windows version.

#4 Updated by Giovanni Manghi almost 8 years ago

Borys Jurgiel wrote:

Ok, than it's related to Python plugins paths, not to the installer.
Unfortunately also I have no access to an affected windows version.

see also #4141

#5 Updated by Giovanni Manghi almost 8 years ago

  • Target version set to Version 1.7.4

#6 Updated by Paolo Cavallini over 7 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Target version changed from Version 1.7.4 to Version 1.8.0

#7 Updated by Steve Tracik about 7 years ago

Still doesn't work in the 1.8.0 version (and MASTER version)

#8 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#9 Updated by Minoru Akagi over 6 years ago

Attatched patch enables loading plugins with a few exceptions.
Found defects:
  • ScriptRunner plugin: fails to be loaded.
  • OpenLayers plugin: Menu icons and layers are not displayed.

I would like to note that there is another solution using --configpath commandline option.

#10 Updated by Anonymous over 6 years ago

  • Status changed from Open to Closed

#11 Updated by Minoru Akagi over 6 years ago

ah, I missed version update.

#12 Updated by Minoru Akagi over 6 years ago

  • Status changed from Reopened to Closed

I should have opened a new ticket (#7537).

Also available in: Atom PDF