Feature request #4299

Change TOC symbology classes order according to order in the "style" tab of the vector properties

Added by Andrew Chapman over 5 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Legend
Pull Request or Patch supplied:No Resolution:fixed/implemented
Easy fix?:No

Description

When using categorized new symbology, if the entries are sorted by Value, the labels can be edited but when they are next loaded, the wrong entries were changed.

As an aside, it would be nice if when the values were sorted (by value or label) this became the new order in both the dialog and Layers window.

History

#1 Updated by Giovanni Manghi over 5 years ago

  • OS version deleted (1.7.0)
  • Tracker changed from Bug report to Feature request
  • Subject changed from New symbology layer properties changing wrong label to Change TOC symbology classes according to ordering in the "style" tab in the vector properties
  • Category changed from GUI to Map Legend
  • Operating System deleted (Windows)

The first par is duplicate of #4334.

I'll change the subject to reflect the feature request in the second part od the description.

#2 Updated by Giovanni Manghi over 5 years ago

  • Subject changed from Change TOC symbology classes according to ordering in the "style" tab in the vector properties to Change TOC symbology classes order according to order in the "style" tab of the vector properties

#3 Updated by Giovanni Manghi over 5 years ago

  • Target version set to Version 1.7.4

#4 Updated by Giovanni Manghi about 5 years ago

  • Target version changed from Version 1.7.4 to Version 2.0.0

#5 Updated by Pirmin Kalberer over 4 years ago

  • Target version changed from Version 2.0.0 to Future Release - Nice to have

#6 Updated by Médéric RIBREUX over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Hello, bug triage...

in QGIS 2.13 master (and probably in previous versions), the order of the categorized and graduated renderers is preserved from what is displayed in the Style tab and what is shown on the Layers Panel.

I am closing this feature request.

Also available in: Atom PDF