Bug report #4209

Fail when using clipper from Gdal Tools

Added by Caio Hamamura about 9 years ago. Updated about 9 years ago.

Status:Rejected
Priority:Normal
Assignee:-
Category:GDAL Tools
Affected QGIS version: Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:14173

Description

When I try to use Clipper from Gdal Tools with a shapefile mask it returns the following error:

Traceback (most recent call last):
File "C:\\OSGeo4W\\apps\\qgis\\python\\plugins\\GdalTools\\tools\\widgetPluginBase.py", line 27, in someValueChanged
self.emit(SIGNAL"), self.getArguments())
File "C:\\OSGeo4W\\apps\\qgis\\python\\plugins\\GdalTools\\tools\\doClipper.py", line 105, in getArguments
return self.getArgsModeMask()
File "C:\\OSGeo4W\\apps\\qgis\\python\\plugins\\GdalTools\\tools\\doClipper.py", line 143, in getArgsModeMask
if self.alphaBandCheck.isChecked():
TypeError: 'sip.methoddescriptor' object is not callable

History

#1 Updated by Caio Hamamura about 9 years ago

It is specific for the plugin in QGIS, since gdal warp -f GTiff -cutline shape.shp srcraster.tif outputraster.tif does works.

#2 Updated by Paolo Cavallini about 9 years ago

  • Resolution set to duplicate
  • Status changed from Open to Rejected

Duplicate of #4191

Also available in: Atom PDF